Betano Ghana

Service unavailable
Resolved·Full outage
Thu, Nov 20, 2025, 09:24 AM
(2 weeks ago)
·
Affected components
Sportsbook
Casino
Updates

Resolved

Good news, a fix has been deployed, which means that in a few moments you will be able to visit our website again! Big thanks for your patience!

Thu, Nov 20, 2025, 09:24 AM

Monitoring

A fix has been implemented and things are looking stable. We’re closely monitoring to ensure everything runs smoothly; thanks again for your patience!

Thu, Nov 20, 2025, 09:22 AM

Identified

We’ve identified the root cause of the issue and are working on applying the fix. Thanks for bearing with us; we’ll keep you posted as we make progress!

Thu, Nov 20, 2025, 09:18 AM

Investigating

Apologies, it seems that something went wrong; please bear with us, as we get ourselves back on track! To check on our progress, feel free to subscribe in the above link.

Thu, Nov 20, 2025, 09:14 AM
Powered by